BLACKOUT MAP

JQuery · JQuery

CVE-2020-11023

Potential XSS vulnerability in jQuery

Exploited in attacks Medium 6.9 Attack chance: 85%
Share

What it is

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

CISA: JQuery contains a persistent cross-site scripting (XSS) vulnerability. When passing maliciously formed, untrusted input enclosed in HTML tags, JQuery's DOM manipulators can execute untrusted code in the context of the user's browser.

Added to the CISA list
January 23, 2025
Published
April 29, 2020
Severity
Medium 6.9 CVSS 3.1
Chance of attacks in the next 30 days (EPSS)
85% in the top 0.3% of all known vulnerabilities
Weakness
CWE-79
More details
NVD · CVE.org · CISA
All references (20)

Sources: Known Exploited Vulnerabilities (CISA, public domain), CVE records (cve.org) and EPSS (FIRST). The chance of attacks is the EPSS estimate that someone will try to exploit the flaw in the next 30 days.