BLACKOUT MAP

JQuery · JQuery

CVE-2020-11023

Potential XSS vulnerability in jQuery

Exploitée dans des attaques Moyenne 6,9 Risque d'attaque : 85%
Partager

De quoi s'agit-il

In jQuery versions greater than or equal to 1.0.3 and before 3.5.0, passing HTML containing <option> elements from untrusted sources - even after sanitizing it - to one of jQuery's DOM manipulation methods (i.e. .html(), .append(), and others) may execute untrusted code. This problem is patched in jQuery 3.5.0.

CISA: JQuery contains a persistent cross-site scripting (XSS) vulnerability. When passing maliciously formed, untrusted input enclosed in HTML tags, JQuery's DOM manipulators can execute untrusted code in the context of the user's browser.

Que faire

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

Échéance pour les agences fédérales américaines : 13 février 2025

Ajoutée à la liste de la CISA
23 janvier 2025
Publiée
29 avril 2020
Gravité
Moyenne 6,9 CVSS 3.1
Probabilité d'attaques dans les 30 prochains jours (EPSS)
85% dans les 0,3% les plus à risque de toutes les failles connues
Faiblesse
CWE-79
Plus de détails
NVD · CVE.org · CISA
Toutes les références (20)

Sources : Known Exploited Vulnerabilities (CISA, domaine public), CVE records (cve.org) et EPSS (FIRST). Le risque d'attaque est l'estimation EPSS qu'une personne tente d'exploiter la faille dans les 30 prochains jours.