BLACKOUT MAP

Apache · Tomcat

CVE-2025-24813

Apache Tomcat: Potential RCE and/or information disclosure and/or information corruption with partial PUT

Exploited in attacks Critical 10.0 Attack chance: 99.9%
Share

What it is

Path Equivalence: 'file.Name' (Internal Dot) leading to Remote Code Execution and/or Information disclosure and/or malicious content added to uploaded files via write enabled Default Servlet in Apache Tomcat.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.2, from 10.1.0-M1 through 10.1.34, from 9.0.0.M1 through 9.0.98.
The following versions were EOL at the time the CVE was created but are
known to be affected: 8.5.0 though 8.5.100. Other, older, EOL versions
may also be affected.


If all of the following were true, a malicious user was able to view security sensitive files and/or inject content into those files:
- writes enabled for the default servlet (disabled by default)
- support for partial PUT (enabled by default)
- a target URL for security sensitive uploads that was a sub-directory of a target URL for public uploads
- attacker knowledge of the names of security sensitive files being uploaded
- the security sensitive files also being uploaded via partial PUT

If all of the following were true, a malicious user was able to perform remote code execution:
- writes enabled for the default servlet (disabled by default)
- support for partial PUT (enabled by default)
- application was using Tomcat's file based session persistence with the default storage location
- application included a library that may be leveraged in a deserialization attack

Users are recommended to upgrade to version 11.0.3, 10.1.35 or 9.0.99, which fixes the issue.

CISA: Apache Tomcat contains a path equivalence vulnerability that allows a remote attacker to execute code, disclose information, or inject malicious content via a partial PUT request. This vulnerability can be chained with CVE‑2026‑34486.

What to do

Apply mitigations per vendor instructions, follow applicable BOD 22-01 guidance for cloud services, or discontinue use of the product if mitigations are unavailable.

Deadline for US federal agencies: April 22, 2025

Added to the CISA list
April 1, 2025
Published
March 10, 2025
Severity
Critical 10.0 CVSS 3.1
Chance of attacks in the next 30 days (EPSS)
99.9% in the top 0.1% of all known vulnerabilities
Weakness
CWE-44 CWE-502
More details
NVD · CVE.org · CISA

More exploited flaws from Apache

AddedVulnerabilityProductSeverityAttack chance
Aug 4, 2026Missing Encryption of Sensitive DataCVE-2026-34486TomcatHigh 7.599%
May 12, 2023Remote Code ExecutionCVE-2016-8735TomcatCritical 9.890%
Mar 25, 2022on Windows Remote Code ExecutionCVE-2017-12615used by ransomwareTomcatHigh 8.199.7%
Mar 25, 2022Remote Code ExecutionCVE-2017-12617TomcatHigh 8.1>99.9%
Mar 3, 2022Improper Privilege ManagementCVE-2020-1938TomcatCritical 9.899.3%
Oct 8, 2026Command InjectionCVE-2016-3081StrutsHigh 8.197%
Apr 16, 2026Improper Input ValidationCVE-2026-34197ActiveMQHigh 8.898%
May 1, 2025Improper Escaping of OutputCVE-2024-38475HTTP ServerCritical 9.1>99.9%

All of them →

Sources: Known Exploited Vulnerabilities (CISA, public domain), CVE records (cve.org) and EPSS (FIRST). The chance of attacks is the EPSS estimate that someone will try to exploit the flaw in the next 30 days.